37 lines
1.2 KiB
BlitzBasic
37 lines
1.2 KiB
BlitzBasic
#
|
|
# Copyright (c) 2023 Fabian Baldeau. All rights reserved.
|
|
#
|
|
|
|
#LICENSE = "BSD-3-Clause"
|
|
#LIC_FILES_CHKSUM = "file:///home/fabian/Desktop/yocto/yocto-build/flutter_elinux/LICENSE;md5=9c0505187083d2bf5a515901bc7eb10d"
|
|
#
|
|
#SRC_URI += "file:///home/fabian/Desktop/yocto/yocto-build/flutter_elinux/build/flutter_assets/"
|
|
#
|
|
#do_install() {
|
|
# install -d ${D}/flutter/
|
|
# cp -r ${WORKDIR}/home/fabian/Desktop/yocto/yocto-build/flutter_elinux/build/flutter_assets/ ${D}/flutter/
|
|
#}
|
|
#INSANE_SKIP:${PN} += "ldflags"
|
|
#FILES:${PN} += "/flutter/*"
|
|
|
|
SUMMARY = "Flutter eLinux Application"
|
|
DESCRIPTION = "Flutter eLinux Application"
|
|
AUTHOR = "Fabian Baldeau"
|
|
HOMEPAGE = "https://avoid.sh/bachelor/flutter_elinux"
|
|
BUGTRACKER = "https://avoid.sh/bachelor/flutter_elinux/issues"
|
|
SECTION = "graphics"
|
|
|
|
LICENSE = "BSD-3-Clause"
|
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=9c0505187083d2bf5a515901bc7eb10d"
|
|
|
|
SRCREV = "9323b4d6271ea31d1c9b8188cb2bbc12d220fd48"
|
|
SRC_URI = "git://avoid.sh/bachelor/flutter_elinux.git;lfs=0;branch=new;protocol=https;destsuffix=git;user=guest:zbGzzNHC"
|
|
|
|
S = "${WORKDIR}/git"
|
|
|
|
PUBSPEC_APPNAME = "flutter_elinux"
|
|
FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
|
|
|
|
FLUTTER_BUILD_ARGS = "bundle"
|
|
|
|
inherit flutter-app |