30 lines
1.2 KiB
BlitzBasic
30 lines
1.2 KiB
BlitzBasic
#
|
|
# Copyright (c) 2023 Fabian Baldeau. All rights reserved.
|
|
#
|
|
|
|
SUMMARY = "Flutter eLinux Application"
|
|
DESCRIPTION = "Flutter eLinux Application"
|
|
AUTHOR = "Fabian Baldeau"
|
|
HOMEPAGE = "https://avoid.sh/bachelor/flutter_elinux"
|
|
BUGTRACKER = "https://avoid.sh/bachelor/flutter_elinux/issues"
|
|
SECTION = "graphics"
|
|
|
|
LICENSE = "BSD-3-Clause"
|
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=9c0505187083d2bf5a515901bc7eb10d"
|
|
|
|
SRCREV = "5438f4a0160219c269c563ee9ae40175f5d21cee"
|
|
SRCREV_vkml = "2445d1612156b1d57474c3a4e8770ef75d98439c"
|
|
SRCREV_rtc = "bb731151f2102ad3c8dbea4891c45cabfcd27220"
|
|
|
|
SRC_URI = "git://avoid.sh/bachelor/flutter_elinux.git;lfs=0;branch=main;protocol=https;destsuffix=git;user=guest:zbGzzNHC \
|
|
gitsm://avoid.sh/bachelor/virtual_keyboard_multi_language.git;lfs=0;branch=master;protocol=https;destsuffix=git/packages/virtual_keyboard_multi_language;user=guest:zbGzzNHC;name=vkml \
|
|
gitsm://avoid.sh/bachelor/real_time_chart.git;lfs=0;branch=main;protocol=https;destsuffix=git/packages/real_time_chart;user=guest:zbGzzNHC;name=rtc "
|
|
|
|
S = "${WORKDIR}/git"
|
|
|
|
PUBSPEC_APPNAME = "flutter_elinux"
|
|
FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
|
|
|
|
FLUTTER_BUILD_ARGS = "bundle"
|
|
|
|
inherit flutter-app |