crops-yocto/poky/meta/recipes-devtools/python/python3-pytz_2022.1.bb
2024-03-01 23:15:01 +01:00

36 lines
840 B
BlitzBasic

SUMMARY = "World timezone definitions, modern and historical"
HOMEPAGE = "http://pythonhosted.org/pytz"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
inherit pypi setuptools3 ptest
SRC_URI[sha256sum] = "1e760e2fe6a8163bc0b3d9a19c4f84342afa0a2affebfaa84b01b978a02ecaa7"
RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-doctest \
${PYTHON_PN}-io \
${PYTHON_PN}-pickle \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/pytz
install -d ${D}${PTEST_PATH}/pytz/tests
cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
cp -f ${S}/README.rst ${D}${PTEST_PATH}/
}